WebElements Record Clears After Save

Moderators: Phil Winkler, Graham Smith, Pete Tabord

WebElements Record Clears After Save

Postby Graham Smith » Thu Oct 20, 2011 8:13 pm

I'm finding that when I enter a record and save with a button (either Save or SaveAs), then it clears the form after saving. It doesn't seem to matter what the properties are set to on the Form/Aspect either.

Is there a way to stop this from happening?
Graham Smith
DataSmith, Delaware
"For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)
"X-Clacks-Overhead: GNU Terry Pratchett"
User avatar
Graham Smith
 
Posts: 2501
Joined: Fri Sep 07, 2007 11:31 am
Location: Delaware, USA
Has thanked: 0 time
Been thanked: 1 time
 

Re: WebElements Record Clears After Save

Postby Adrian Jones » Fri Oct 21, 2011 12:35 pm

Do you mean that the behaviour of the webform is different if a button is in place, rather than using the 'save' option on that orange menu bar thing?

Or that however you save, it clears?
User avatar
Adrian Jones
 
Posts: 2000
Joined: Tue Sep 11, 2007 2:38 pm
Location: Cornwall, UK
Has thanked: 5 times
Been thanked: 4 times
 

Re: WebElements Record Clears After Save

Postby Graham Smith » Mon Oct 24, 2011 12:10 pm

Not sure if it is different, I don't use the built in menu bars. But, somehow, I doubt it is different.
Graham Smith
DataSmith, Delaware
"For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)
"X-Clacks-Overhead: GNU Terry Pratchett"
User avatar
Graham Smith
 
Posts: 2501
Joined: Fri Sep 07, 2007 11:31 am
Location: Delaware, USA
Has thanked: 0 time
Been thanked: 1 time
 

Re: WebElements Record Clears After Save

Postby Adrian Jones » Mon Oct 24, 2011 12:31 pm

I'd have to look (which means wading through ASP code), but I wouldn't assume that the code to interpret button actions is the same as the orange toolbar.

But either way, I suspect that it is not a case of clearing the form as much as forgetting to ask for the data back again. As you know, there is (currently) no logic on the webpage to keep derivations, etc, in synch as data-entry is occuring, and so it is only when the data is submitted that the true value of derived fields can be shown to the user. That means asking for it back again from the webcom part of Web Elements.

To do that would mean making a change to the ASP code that generates the webpage.

An overhaul of W/E is on the cards, but as you can appreciate is playing second fiddle to 1.53. Most of that overhaul would lie in the ASP code (I'd like to move it to PHP, anyway) which actually is an option open to anyone who has the patience and skill to undertake the task.

(Other changes I'd like to see include the so-called 'refresh' option we've spoken about before, and some minor-ish changes to the XML metadata produced for each document.)
User avatar
Adrian Jones
 
Posts: 2000
Joined: Tue Sep 11, 2007 2:38 pm
Location: Cornwall, UK
Has thanked: 5 times
Been thanked: 4 times
 

Re: WebElements Record Clears After Save

Postby Graham Smith » Mon Oct 24, 2011 3:12 pm

Phil has a test app that seems to be working as it should - that is, it is not clearing the form after a save. My copy of WebElements is highly customized to remove all the buttons and the space they take up etc so it's possible that in doing so, I have inadvertently changed something that's effecting the behavior. I'm going to get a copy of what Phil has installed and try that to see if it's any different.
Graham Smith
DataSmith, Delaware
"For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)
"X-Clacks-Overhead: GNU Terry Pratchett"
User avatar
Graham Smith
 
Posts: 2501
Joined: Fri Sep 07, 2007 11:31 am
Location: Delaware, USA
Has thanked: 0 time
Been thanked: 1 time
 

Re: WebElements Record Clears After Save

Postby Graham Smith » Mon Oct 24, 2011 8:54 pm

This is just crazy. I took a copy of Phil's app and tested it, and the form does not clear. What the difference is, I'm not sure but I've changed everything I can think of to match between the two apps and the two behave differently. I've regenerated each app so many times, the keystrokes are burned into my retinas.

I'm going to start a whole new app from scratch and see what it does.
Graham Smith
DataSmith, Delaware
"For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)
"X-Clacks-Overhead: GNU Terry Pratchett"
User avatar
Graham Smith
 
Posts: 2501
Joined: Fri Sep 07, 2007 11:31 am
Location: Delaware, USA
Has thanked: 0 time
Been thanked: 1 time
 

Re: WebElements Record Clears After Save

Postby Graham Smith » Wed Oct 26, 2011 8:37 pm

Here is the latest. I have created a new app and installed a couple forms and aspects from the other app and they work fine. The records don't clear with a save. I am absolutely stumped as to why this is happening.
Graham Smith
DataSmith, Delaware
"For every expert there is an equal and opposite expert.", Arthur C. Clarke (1917 - 2008)
"X-Clacks-Overhead: GNU Terry Pratchett"
User avatar
Graham Smith
 
Posts: 2501
Joined: Fri Sep 07, 2007 11:31 am
Location: Delaware, USA
Has thanked: 0 time
Been thanked: 1 time
 
 

Return to Ffenics WebElements

Who is online

Users browsing this forum: No registered users and 1 guest

cron